Monday, December 24, 2012

Install and Configure SharePoint Server 2013 Step by Step

 

You are reading :  SharePoint Server 2013 installation Part 3

In previous post we’ve installed SQL Server 2012, Now for SharePoint installation I’ve logged in with SPAdmin

account, and also have created one more account for which will have administrator rights on SharePoint farm i.e. svcSPFarm.

1) Download : SharePoint Server 2013

2) Mount ISO file. and start installation process.

InstallationScreen

Before starting installation SharePoint Server, need to install software prerequisites.

So click on Install software prerequisites.

Note : you need active internet connection.Because it downloads updates from Microsoft Download Center.

Prerq

Accept and terms and licence agreement and go next.

CompletePrereqInstallation

Once installation of Prerequisite is done. Click on Install SharePoint Server

 InstallationScreen

Enter product key and Continue.

Accept Terms and Continue.

Keep Path of Server as it is and click on Install Now

PathofServerl

This will install SharePoint Server on your machine.

InstallationProcess

Next step is to Run the SharePoint Configuration Wizard

RunWizard

By clicking on Close button, Wizard will run. If you want to run it later you can find it in start menu.

WelcomeSharePoint

Click on Next.

ServiceRestart

Click on Yes.

CreateNewServerFarm

Select Create a new server farm. and click Next

Enter Database server name (Server name on which SQL Server is installed).

Username : zsdev\svcSPFarm (which I’ve created in Active Directory) This Service Account will have full access on

SharePoint Config Database

Password : (Password set for svcSPFarm account)

DatabseConnection

SP13 is the server name where SQL Server is installed. click Next

Enter Passphrase. and don’t forget it. because next time when you will need to reconfigure farm at the time of update installation. It will ask you for Passphrase.

Passphrase

Specify Central Administration Portal port. you can change it if you want.

keep authentication provider : NTLM

SpecifyPort 

I’ve change port number to 1111 from 17685.

CompleteConfigWizard

Click Next.

ConfigProcess

and Configuration is completed.

CompleteConfig1

Click on Finish button. This will open Central Admin web page.

NoConfigSharePointFarm

Click on Cancel button for SharePoint Configuration Farm. It will redirect you to Central Administration.

IE

Here it is complete SharePoint Server Configuration.

 

Also read :

Thanks,

If any query please post comments

25 comments:

  1. Great set of posts, many thanks for putting them together.

    Could I suggest adding a step after the prerequisites have been installed - Check Windows Update. I had 13 updates waiting after the prerequisites, for Server 2012, .NET 3.5 and .NET 4.5

    ReplyDelete
  2. Many Many Many thanks for you post :)

    ReplyDelete
  3. Excellent Post, It helped me a lot set up my sharepoint farm in no time

    ReplyDelete
  4. Nice Everything in Single Place

    ReplyDelete
  5. Many, Many thanks for giving such important information.

    ReplyDelete
  6. thank a lot. i sincerely appreciate. remain bless.

    ReplyDelete
  7. Should we follow the same for "Single Server Installation" ?

    ReplyDelete
  8. I like this post but I guess one is very important piece is missing that is service account and setting up permission on the SharePoint server before installation.

    Thanks.

    ReplyDelete
  9. This comment has been removed by the author.

    ReplyDelete
  10. Thanks very much for the great job and your help.

    For my part, I had a problem during install of prerequisites with this message: • Application Server Role, Web Server (IIS) Role: configuration error
    I searched on the net unfortunately didn't find how to fix.
    Could you please advise.

    thanks in advance.

    ReplyDelete
    Replies
    1. rename the file C:\windows\System32\ServerManager.exe to ServerManagerCMD.exe

      then run prerequisiteinstaller

      Delete
  11. Please use this link fro the configuration errors, it worked for me.
    http://www.avivroth.com/2013/07/09/installing-sharepoint-2013-on-windows-server-2012-r2-preview/

    ReplyDelete
  12. Using a Min-Priv Model, SPAdmin is the service account that is used to run cinfiguration wizard. SPFarm is used later to run the Timer Service and the Central Administration Web Application.

    ReplyDelete
  13. Many thanks for the information provided. very informative.

    ReplyDelete
  14. I need your help. I have spent hours trying to create a new server farm but nothing seems to work. I have checked and triple checked the instance name, the login and user permission, disabled firewall, made sure SQL server browser is running but still nothing. I don’t know what to do again

    ReplyDelete
  15. Thank You so much for this post. really made things easy for me to get share poin up and running.

    ReplyDelete
  16. first thanks for the good article, please tell me how can you test web front end servers?

    ReplyDelete
  17. Good tut. If anyone gets 503 errors after configuration install (instead of the web page) then I found this on the web and it helped me:

    Goto IIS manager ->Application Pool,
    click 'SharePoint Central Administration v4'
    Right click Advanced settings,
    and set "Enable 32-bit applications" to "False"

    I also had to do the same with the default pool as well. I had to do this to get the SP configuration page to work, as well as all the other websites in IIS before the install of SP. Something in the install messed them up!

    Also, nothing worked for me until dozens and dozens more of updates were installed for SP.

    ReplyDelete
  18. If anyone gets a "Application Server Role, Web Server (IIS) Role: configuration error". I solved this by running the following command on an elevated command line "Dism /online /enable-feature /featurename:NetFx3 /All /Source:D:\sources\sxs /LimitAccess" where D: is your mounted W2K12R2 iso.

    ReplyDelete
  19. Hello! I am facing a very different problem here. In the prerequisites everything went well. The installation went smoothly. During the installation the procedure did not ask from the port where the webadminisrator could be installed neither did did it ask for database name and location.
    Now the installation is successful but the Central Administration shows a blank page.
    What I am missing here?
    I have not yet configured the server for a domain, is it necessary???

    ReplyDelete
  20. Deployment Diagram with explanation plz

    ReplyDelete